HomePage Forums Troubleshooting CPR Call Blocker Virgin Media Caller ID Issues

Topic Resolution: Not a Question

This topic contains 0 replies, has 1 voice, and was last updated by  cprsupport 1 year, 3 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #996

    If your telephone/internet provider is Virgin Media and you are experiencing issues with Caller ID, please check first with them that their Caller ID service is part of your telephone package.  Virgin Media do offer free Caller ID, however you need to contact them to have this added to your subscription.  They also offer ones that are chargeable so make sure that this is active on the line at least 24-48 hrs prior to connecting your call blocker on your line.  Please also ensure, if you are using a BT 4600 or other phones with built in call blocking features, that those features are turned off as it will interfere with the Call Blocker programming codes.

    Depending on your area, if your internet is via coax cables (fibre optic) with them, you will have a separate telephone access wall jack which does not require you to use any ADSL filter on it.  Using a filter on it, can cause issues with the Caller ID coming through from the Virgin Media distribution box.  If you have a ADSL connection where the modem and the telephone line is not through fibre optic coax cabling and are experiencing  issues with caller ID, please disconnect everything including all ADSL filters on the line.  Connect only the Call Blocker and a single phone in series, then reconnect each device/filter one at a time checking the line after each device/filter is added to the line.  When you find the filter/device that is causing the interference remove it and if it is a filter, try replace it with a high quality filter like  NETGEAR, BELKIN, D-LINK or ADSL NATION XF1e branded filters.  If you still experience issues, try setting up your call blocker in the Parallel Set up.

    If you have any further issues, please contact us.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.